zoukankan      html  css  js  c++  java
  • Identity Card

    Identity Card

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 995 Accepted Submission(s): 310
    Problem Description
    Do you own an ID card?You must have a identity card number in your family's Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
    Here is the codes which represent the region you are in.

    However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
    Here is Samuel's ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).
     
    Input
    Input will contain 2 parts:
    A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.
     
    Output
    Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.
     
    Sample Input
    1
    330000198910120036
     
    Sample Output
    He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
     
    #include <iostream>
    using namespace std;
    int main()
    {
        int n,t;
       // char id[18];
        string home,id;
        cin>>n;
        for(int k = 0 ; k < n ; k++)
        {
            cin>>id;
            t = (id[0]-'0')*10+id[1]-'0';
            switch(t)
            {
                case 11:home = "Beijing";break;
                case 31:home = "Shanghai";break;
                case 21:home = "Liaoning";break;
                case 33:home = "Zhejiang";break;
                case 54:home = "Tibet";break;
                case 71:home = "Taiwan";break;
                case 81:home = "Hong Kong";break;
                case 82:home = "Macao";break;
                default :break;
            }
            cout<<"He/She is from "<<home<<",and his/her birthday is on "
            <<id[10]<<id[11]<<","<<id[12]<<id[13]<<","<<id[6]<<id[7]<<id[8]<<id[9]
            <<" based on the table."<<endl;
        }
        return 0;
    }
  • 相关阅读:
    C#面向对象
    CSS样式表---------第三章:样式属性
    CSS样式表-------第二章:选择器
    CSS样式表------第一章:样式表的基本概念
    解决Web部署 svg/woff/woff2字体 404错误
    sql server 2012 如何收缩事务日志
    input file类型,文件类型的限制
    C#对XML、JSON等格式的解析
    SQL实现表名更改,列名更改,约束更改
    sql 坐标距离排序计算距离(转)
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2114928.html
Copyright © 2011-2022 走看看