zoukankan      html  css  js  c++  java
  • 背包问题

    Bone Collector

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 25800    Accepted Submission(s): 10453


    Problem Description
    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

     

    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     

    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     

    Sample Input
    1 5 10 1 2 3 4 5 5 4 3 2 1
     

    Sample Output
    14
     

    #include<iostream>
    using namespace std;
    int max(int a,int b)
    {if(a>b)
    return a;
    else return b;}
    int n,j,v,c[1004],w[1004],dp[1004][1004],k,i;
    int main()
    {
    	
    	cin>>k;
    	while(k--)
    	{
    		memset(dp,0,sizeof(dp));
    		cin>>n>>v;
    		for(i=1;i<=n;i++)
    			cin>>c[i];
    		for(i=1;i<=n;i++)
    			cin>>w[i];
    		
    		for(i=1;i<=n;i++)
    			for(j=0;j<=v;j++)
    				if(w[i]<=j)
    				dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+c[i]);
    				else 
                        dp[i][j]=dp[i-1][j];  
                       cout<<dp[n][v]<<endl;
    	}
    return 0;
    }

  • 相关阅读:
    WPF中任务栏只显示主窗口
    makefile经典教程
    Linux常见指令大全
    ubuntu下 fdisk用法
    将SD系统启动卡恢复成普通卡
    1、采用SD启动盘bootingLinux
    Soc常见问题
    ARM Linux 3.x的设备树(Device Tree)
    DS-5获取License
    Soc EmbeddedDesign Suite (EDS)13.1.0.162安装
  • 原文地址:https://www.cnblogs.com/oversea201405/p/3766936.html
Copyright © 2011-2022 走看看