zoukankan      html  css  js  c++  java
  • HDOJ1022(模拟栈)

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 31758    Accepted Submission(s): 11976


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
    3 123 321
    3 123 312
     
    Sample Output
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    #include <iostream>
    #include <stack>
    #include <string>
    using namespace std;
    const int MAXN=20;
    char o1[MAXN],o2[MAXN];
    int n;
    string op[MAXN];
    int top;
    int main()
    {
        while(cin>>n)
        {
            cin>>o1>>o2;
            top=0;
            stack<char> st;
            for(int i=0,j=0,len=strlen(o1);i<len;i++)
            {
                st.push(o1[i]);
                op[top++]="in";
                while(st.top()==o2[j])
                {
                    st.pop();
                    j++;
                    op[top++]="out";
                    if(st.empty())    break;
                }
            }
            if(st.empty())
            {
                cout<<"Yes."<<endl;
                for(int i=0;i<top;i++)
                {
                    cout<<op[i]<<endl;
                }
            }
            else    cout<<"No."<<endl;
            cout<<"FINISH"<<endl;
        }
        
        return 0;
    }
  • 相关阅读:
    转载:ORA-01438: 值大于为此列指定的允许精度
    PLSQL碰到pls-00103的错误解决办法
    spring 的xml配置使用p标签简化
    spring aop实现拦截接口请求打印日志
    response 设置头的类型 (转)
    js或者ext js获取返回值
    ext grid 前台grid加载数据碰到数据重复只显示一条
    关于struts和Spring 结合到一起之后存在ACtion创建单实例还是多
    SVN提交碰到的问题奇怪的问题
    关于项目使用可配置的properties 文件的实现
  • 原文地址:https://www.cnblogs.com/program-ccc/p/4691725.html
Copyright © 2011-2022 走看看