zoukankan      html  css  js  c++  java
  • 01-复杂度2 Maximum Subsequence Sum (25 分)

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    #include<cstdio>
    const int maxn = 100100;
    int a[maxn] = {0};
    int dp[maxn] = {0};
    int s[maxn] = {0};
    
    int main(){
        int n;
        scanf("%d",&n);
        bool flag = false;
        for(int i = 0; i < n; i++){
            scanf("%d",&a[i]);
            if(a[i] >= 0) flag = true;
        }
        if(!flag){
             printf("0 %d %d",a[0],a[n-1]);
             return 0;
        }
        //scanf("%d",&n);
        dp[0] = a[0];
        for(int i = 1; i < n; i++){
            if(dp[i-1] + a[i] >= a[i]){
                dp[i] = dp[i-1]+a[i];
                s[i] = s[i-1];
            }else{
                dp[i] = a[i];
                s[i] = i;
            }
        }
        int max = dp[0];
        int k = 0;
        for(int i = 1; i < n; i++){
            if(dp[i] > max){
                max = dp[i];
                k = i;
            }
        }
        printf("%d %d %d",max,a[s[k]],a[k]);
        return 0;
    }
  • 相关阅读:
    30个php操作redis经常用法代码样例
    Android语音播报、后台播报、语音识别
    Gym 100733J Summer Wars 题解:灵活运用扫描线的思想
    如何运营一个软件微社区
    关于迭代测试的一些思考
    DirectUI界面编程(五)WindowImplBase的使用
    Zxing实现在线二维码生成程序
    Java二维码生成与解码工具Zxing使用
    DirectUI界面编程(四)界面布局详解
    软件开发中的资源管理
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10548671.html
Copyright © 2011-2022 走看看