zoukankan      html  css  js  c++  java
  • 图论

    PAT甲级 1003 Emergency C++

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

    Output Specification:

    For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input:

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1

    Sample Output:

    2 4

    由于初学图论此题参考了柳神的代码:
    https://blog.csdn.net/liuchuo/article/details/52300668
    这个小姐姐代码写的很好,大家可以多去逛逛她的博客哦!:
    https://www.liuchuo.net/

    题目大意:

    n个城市m条路,每个城市有救援小组,所有的边的边权已知。给定起点和终点,求从起点到终点的最短路径条数以及最短路径上的救援小组数目之和。如果有多条就输出点权(城市救援小组数目)最大的那个

    分析

    用一遍Dijkstra算法~救援小组个数相当于点权,用Dijkstra求边权最小的最短路径的条数,以及这些最短路径中点权最大的值~dis[i]表示从出发点到i结点最短路径的路径长度,num[i]表示从出发点到i结点最短路径的条数,w[i]表示从出发点到i点救援队的数目之和~当判定dis[u] + e[u][v] < dis[v]的时候,不仅仅要更新dis[v],还要更新num[v] = num[u], w[v] = weight[v] + w[u]; 如果dis[u] + e[u][v] == dis[v],还要更新num[v] += num[u],而且判断一下是否权重w[v]更小,如果更小了就更新w[v] = weight[v] + w[u].

    #include <iostream>
    #include <algorithm>
    
    using namespace std;
    int n, m, c1, c2;
    int e[510][510], weight[510], dis[510], num[510], w[510];
    //num表示不同最短路径的数量 w表示可以到达各个点的最大队伍数量
    bool visit[510]; 
    const int inf = 99999999;
    
    int main() {
    	scanf("%d%d%d%d", &n, &m, &c1, &c2);
    	for (int i = 0; i < n; i++)
    		scanf("%d", &weight[i]);
    	//初始化操作
    	fill(e[0], e[0] + 510 * 510, inf);
    	fill(dis, dis + 510, inf);
    	//读入边
    	int a, b, c;
    	for (int i = 0; i < m; i++) {
    		scanf("%d%d%d", &a, &b, &c);
    		e[a][b] = e[b][a] = c;
    	}
    	//初始化源点
    	dis[c1] = 0;
    	w[c1] = weight[c1]; //初始化源点到自己的队伍数
    	num[c1] = 1;        //初始化源点到自己的路径数量
        //Dijkstra算法核心
    	for (int i = 0; i < n; i++) 
    	{
    		int u = -1, minn = inf;
    		//找到当前距离源点最近的点
    		for (int j = 0; j < n; j++) 
    		{
    			if (visit[j] == false && dis[j] < minn) 
    			{
    				u = j;
    				minn = dis[j];
    			}
    		}
    		if (u == -1) break; //如果以上的点都被遍历完就停止
    		visit[u] = true;
    		//寻找经过该中转点可以直接到达的点
    		for (int v = 0; v < n; v++) 
    		{
    			if (visit[v] == false && e[u][v] != inf) 
    			{
    				if (dis[u] + e[u][v] < dis[v]) //如果此时是最短路径 
    				{
    					dis[v] = dis[u] + e[u][v]; //更新最短路径长度
    					num[v] = num[u];           
    					w[v] = w[u] + weight[v];   //更新最短路路径的最大队伍数量
    				}
    				else if (dis[u] + e[u][v] == dis[v]) 
    				{
    					num[v] = num[v] + num[u];
    					if (w[u] + weight[v] > w[v])
    						w[v] = w[u] + weight[v];
    				}
    			}
    		}
    	}
    	printf("%d %d", num[c2], w[c2]);
    	return 0;
    }
    
  • 相关阅读:
    常用正则表达式
    C# 计算时间差 用timespan函数
    SQL Server日期时间格式转换字符串详解
    .net数据根据字段进行分类(linq语句)
    IIS设置允许下载.exe文件解决方法
    IIS 添加mime 支持 apk,exe,.woff,IIS MIME设置 ,Android apk下载的MIME 设置 苹果ISO .ipa下载mime 设置
    高版本jQuery设置checkbox状态注意事项
    sql大小转换函数
    常用的正则验证
    position布局影响点击事件以及冒泡获取事件目标
  • 原文地址:https://www.cnblogs.com/wlw-x/p/11521323.html
Copyright © 2011-2022 走看看