zoukankan      html  css  js  c++  java
  • HDU——1019Least Common Multiple(多个数的最小公倍数)

    Least Common Multiple

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 42735    Accepted Submission(s): 16055

    Problem Description
    The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

     
    Input
    Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
     
    Output
    For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
     
    Sample Input
    2 3 5 7 15 6 4 10296 936 1287 792 1
     
    Sample Output
    105 10296
     
    这题百度了下有出现n=1的情况,按我之前先取两个数得到第一个公倍数的做法会超时,n=1根本没无法输出。因此要重新写,顺便复习下gcd公式
    代码:
    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    long long gcd(long long a,long long b)
    {
      return b?gcd(b,a%b):a;//还是记这个吧,简单易用
    } 
    int main()
    {
        int t;
        cin>>t;
        while (t--)
        {
        	int n;
    		long long  a,tlcm,beg=1;//让beg初始化为1不影响结果并成为第0个数,这样一开始也就可以一个一个地求gcd
        	scanf("%d",&n);
        	for (int i=0; i<n; i++)
        	{
    	    	scanf("%lld",&a);
    	    	beg=(beg*a)/gcd(a,beg);
    	    }
        	cout<<beg<<endl;
        }
        return 0;
    }
  • 相关阅读:
    UVA 11806 组合数学+容斥
    Educational Codeforces Round 37 (Rated for Div. 2) G
    java 5 线程池
    团队-象棋游戏-项目进度
    结对-五子棋-测试过程
    结对-五子棋游戏-开发过程
    课后作业-阅读任务-阅读提问-2
    20171006-构建之法:现代软件工程-阅读笔记
    结队-五子棋游戏-项目进度
    团队-象棋游戏-代码设计规范
  • 原文地址:https://www.cnblogs.com/Blackops/p/5356444.html
Copyright © 2011-2022 走看看