zoukankan      html  css  js  c++  java
  • POJ1065--Wooden Sticks(动态规划)

    There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
    (a) The setup time for the first wooden stick is 1 minute. 
    (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
    You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

    Output

    The output should contain the minimum setup time in minutes, one per line.

    Sample Input

    3 
    5 
    4 9 5 2 2 1 3 5 1 4 
    3 
    2 2 1 1 2 2 
    3 
    1 3 2 2 3 1 
    

    Sample Output

    2
    1
    3



    #include<iostream>
    #include<algorithm> 
    #include<string.h> 
    using namespace std;
    
    struct node{
        int l,w;
    }stick[5005]; 
    int use[5005];
    bool operator<(node a,node b){
        if(a.l==b.l)
            return a.w<b.w;
        else
            return a.l<b.l;
    }
    int main(){
        int t;
        cin>>t;
        while(t--){
            int n;
            cin>>n;
            memset(use,0,sizeof(use));
            for(int i=0;i<n;i++){
                cin>>stick[i].l>>stick[i].w;
            }
            sort(stick,stick+n);
            int ans=0;
            node last;
            for(int i=0;i<n;i++){
                last.w=stick[i].w;
                if(use[i]==0){
                    for(int j=i+1;j<n;j++){
                        if(last.w<=stick[j].w&&use[j]==0){
                            last.w=stick[j].w;
                            use[j]=1;
                        }
                    }
                    ans++;
                } 
            }
            cout<<ans<<endl;
        }
        return 0;
    }


  • 相关阅读:
    Geoserver通过ajax跨域访问服务数据的方法(含用户名密码认证的配置方式)
    123
    递归____蛮好的例子 蓝桥
    博弈_____威佐夫博奕
    123123
    sort
    int ,long , long long类型的范围
    数学推导_循环小数转分数
    下一步:结构体 背包 库函数
    回溯____蓝桥 棋盘
  • 原文地址:https://www.cnblogs.com/albert67/p/10324230.html
Copyright © 2011-2022 走看看