zoukankan      html  css  js  c++  java
  • hdu 1047

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10588    Accepted Submission(s): 2737


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
     
    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.
     
    Output
    Your program should output the sum of the VeryLongIntegers given in the input.


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     
    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     
    Sample Output
    370370367037037036703703703670
     
    Source
     
    Recommend
    We have carefully selected several similar problems for you:  1042 1063 1316 1715 1753 
     
     
    import java.io.File;
    import java.io.FileNotFoundException;
    import java.math.BigInteger;
    import java.util.Scanner;
    
    
    public class Main {
    
    	/**
    	 * @param args
    	 * @throws FileNotFoundException 
    	 */
    	public static void main(String[] args) throws FileNotFoundException {
    		// TODO Auto-generated method stub
    //		File f = new File("F:\pro\javaPro\hdu2054\in");
    		Scanner s = new Scanner(System.in);
    		int n=s.nextInt();
    		BigInteger b = new BigInteger("0");
    		for(int i=0; i<n; i++){
    			while(true){
    				String a = s.next();
    //				System.out.println(b+" "+a);
    
    				if(a.equals("0")){
    					if(i>0) System.out.println();
    					System.out.println(b);
    					b = BigInteger.ZERO;
    					break;
    				}
    				else b=b.add(new BigInteger(a));
    			}
    		}
    	}
    
    }
    
  • 相关阅读:
    蓝牙4.0BLE cc2540 cc2541 ios OAD课程(空中固件升级)[原版的,多图]
    ASP.NET文件上传和下载
    onethink和phpwind共享
    折返(Reentrancy)VS线程安全(Thread safety)
    使用更清晰DebugLog开发和调试工具
    MySql分析算法作品索引(马上,只是说说而已B-tree)
    使用shell命令分析统计日志
    刷牙LeetCode思考
    Cocos3d-x 发布第一版
    SSH连接Linux的Server超时
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3585592.html
Copyright © 2011-2022 走看看